[guardian-dev] android-9 (2.3) minimum for cacheword?

Hans-Christoph Steiner hans at guardianproject.info
Thu Aug 21 20:26:12 EDT 2014


Since we're often caught in hellish loops of jar version conflicts and the
like, I'd like to remove as many dependencies from cacheword as possible.  For
example, it looks like the only thing we really need spongycastle is to
support Android 2.2 and older (i.e. older than android-9).  ChatSecure,
Courier, JustPay, NoteCipher, and InformaCam are already minSdkVersion="9" or
newer.

Anyone have a compelling reason to maintain support for android-8 and older?

I've opened an issue to keep track of the details:
https://dev.guardianproject.info/issues/3665

.hc

-- 
PGP fingerprint: 5E61 C878 0F86 295C E17D  8677 9F0F E587 374B BE81


More information about the Guardian-dev mailing list