[guardian-dev] building orbot

Hans-Christoph Steiner hans at guardianproject.info
Tue May 31 09:10:36 EDT 2016



Nathan of Guardian:
> 
> 
> On Tue, May 31, 2016, at 05:05 AM, Hans-Christoph Steiner wrote:
>> How are you building Orbot these days?  Do you need to use old versions
>> of the SDK?  I can't get it going as it is in git.
> 
> I haven't made the update to Gradle yet, but it should build from Ant
> still.
> 
> Where is it failing? Are you using make-release-build?

Tried using ./make-release-build and Eclipse.  Both are failing with an
exception that seems to be something related to Java8, I think.  So my
guess is that the ant builds no longer work with the latest Android SDK:

[dx] Exception in thread "main" java.lang.UnsupportedClassVersionError:
com/android/dx/command/Main : Unsupported major.minor version 52.0
[dx] 	at java.lang.ClassLoader.defineClass1(Native Method)
[dx] 	at java.lang.ClassLoader.defineClass(ClassLoader.java:803)
[dx] 	at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
[dx] 	at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)


.hc


-- 
PGP fingerprint: EE66 20C7 136B 0D2C 456C  0A4D E9E2 8DEA 00AA 5556
https://pgp.mit.edu/pks/lookup?op=vindex&search=0xE9E28DEA00AA5556


More information about the guardian-dev mailing list